Suppression/AoS Not Triggering

Post Reply
Swiftless
Posts: 59
Joined: Wed Apr 26, 2017 4:31 pm

Suppression/AoS Not Triggering

Post by Swiftless » Sat Aug 12, 2017 5:53 am

I've been noticing a lot of weird instances of a advent under Suppression or Area of Suppression not triggering a shot when they move. I just had an advent Gunner move 6 squares in LOS while suppressed without triggering a shot. Several Ops ago I had one under area of suppression and he waltzed out from the middle of the area without triggering a shot (it was a Guardian iirc). These are non-shadowstepping advent so I'm not sure what's going on.

Anyone seeing the same issue(s) or could there be something going on I'm not understanding?

Icarus
Posts: 151
Joined: Thu Apr 06, 2017 12:26 pm

Re: Suppression/AoS Not Triggering

Post by Icarus » Sat Aug 12, 2017 9:08 am

You need to keep in mind that the ammo cost associated with suppression is simply for activating the ability. You will need another shot for each enemy you want to actually fire on during suppression.

Kwic
Posts: 35
Joined: Thu Apr 06, 2017 12:13 pm

Re: Suppression/AoS Not Triggering

Post by Kwic » Sat Aug 12, 2017 3:06 pm

Remember also, that the unit has to move FORWARD. If it moves backward, then no shot.

bountygiver
Posts: 74
Joined: Mon Feb 27, 2017 3:33 am

Re: Suppression/AoS Not Triggering

Post by bountygiver » Sat Aug 12, 2017 4:38 pm

Icarus wrote:You need to keep in mind that the ammo cost associated with suppression is simply for activating the ability. You will need another shot for each enemy you want to actually fire on during suppression.
this only applies to area suppression. There is LOS problems with suppression that if they move out of LOS on the first tile the suppression shot won't trigger.

Fixable with http://steamcommunity.com/sharedfiles/f ... =628207417 , don't forget to uncomment out the LW ability lines and re-enable reaction penalty if you want suppression to have reaction penalty.

Swiftless
Posts: 59
Joined: Wed Apr 26, 2017 4:31 pm

Re: Suppression/AoS Not Triggering

Post by Swiftless » Sat Aug 12, 2017 7:14 pm

I had plenty of ammo left when it happened. I always check before hand so that I don't waste suppression b/c I didn't have ammo for a shot. I think it might have been the move to an adjacent square without LOS but it's always hard to tell with the LOS quirks in Xcom2. Just when you think you should have LOS, you don't and when you think uou don't you do.

Didn't know about forward movement on AoS.

Thanks for the link, I'll give it a try.

LordYanaek
Posts: 940
Joined: Mon Jan 23, 2017 1:34 pm

Re: Suppression/AoS Not Triggering

Post by LordYanaek » Sat Aug 12, 2017 8:05 pm

Kwic wrote:Remember also, that the unit has to move FORWARD. If it moves backward, then no shot.
Not exactly true. As -bg- explained suppression will fail if the unit suppressed moves out of LoS. This usually occurs when they move backwards but not always. The same is true for regular OW and also for Kill Zone (that last one is particularly tricky because if an enemy is exactly on one of the outermost tiles and moves out of the AoE your soldier won't shoot).

Note : this is a double edged sword and you can use it to your advantage to escape from enemy OW.
Note 2 : unless that part was "fixed" in some way, an enemy who "escapes" from suppression without triggering the shot will still be suppressed after moving (and thus will have reduced aim and won't be able to use some abilities) so your suppression wasn't totally wasted (usually i even prefer when they stay in the area and take a pot shot rather than move, take some wound and then rocket me).

Post Reply