1.3 Evac Bug

Post Reply
oesis
Posts: 38
Joined: Mon Jan 23, 2017 11:36 pm

1.3 Evac Bug

Post by oesis » Mon May 15, 2017 4:37 am

I was playing a smash and grab on 1.3, and I cannot Evac. The Evac spawned on the edge of the map so only 2/3 of it was visible. However even on the 2/3 it doesn't let you evac. When I save load, the indicator for evac shows up. but after doing any movement, it disappears. I was using gotcha again and perfect information, however removing them did not let me evac.

tracktwo
Long War Dev
Posts: 241
Joined: Sat Jan 07, 2017 7:43 pm

Re: 1.3 Evac Bug

Post by tracktwo » Mon May 15, 2017 4:45 am

Thanks for the report. Do you still have the save with the bad evac spot? Several of the map plots have edges in weird places that can sometimes cause an evac zone to spawn partially off-map. It's hard to track these down since they're randomly chosen out of hundreds of possibilities. If you can send a link to a save in the mission we can track down which one is the problem.

As a workaround you can use the console: "\EnableGlobalAbility Evac". This will let you throw a flare. You can use "\LWForceEvac" to skip the countdown.

oesis
Posts: 38
Joined: Mon Jan 23, 2017 11:36 pm

Re: 1.3 Evac Bug

Post by oesis » Mon May 15, 2017 5:03 am

Yes, I still have the file. How do I post to these forums? Do I just find some random upload site, or is there a preferred method?

tracktwo
Long War Dev
Posts: 241
Joined: Sat Jan 07, 2017 7:43 pm

Re: 1.3 Evac Bug

Post by tracktwo » Mon May 15, 2017 6:05 am

The easiest way is just to put it on a random upload site or a link on a cloud storage service like dropbox/gdrive/etc. Thanks again.

oesis
Posts: 38
Joined: Mon Jan 23, 2017 11:36 pm

Re: 1.3 Evac Bug

Post by oesis » Tue May 16, 2017 3:21 am

I'm trying to find the save game, But in the savedata file everything just has numbers(IE save1, save2... ext). How do I find which one is the correct save.

DaviBones
Posts: 75
Joined: Mon Apr 03, 2017 8:30 pm

Re: 1.3 Evac Bug

Post by DaviBones » Tue May 16, 2017 11:21 pm

Sorting the save files by "Date modified" may help.

To actually figure it out though you just need to open the file in a text editor (notepad will work but notepad++ will make it a bit easier) and about 30-40 characters you will find the actual save's name which is listed in-game.

oesis
Posts: 38
Joined: Mon Jan 23, 2017 11:36 pm

Re: 1.3 Evac Bug

Post by oesis » Wed May 17, 2017 7:12 pm

This should be the save file.

https://ufile.io/w7hub

tracktwo
Long War Dev
Posts: 241
Joined: Sat Jan 07, 2017 7:43 pm

Re: 1.3 Evac Bug

Post by tracktwo » Thu May 18, 2017 4:43 am

Thanks for the save! I have a fix for this issue and it'll be in the next update.

In the meantime, if you find yourself in this situation you can work around the bug by throwing a new evac flare with some help from the console:

Code: Select all

\EnableGlobalAbility PlaceEvacZone
\LWForceEvac
The first one lets you throw a new flare, but will give you an evac countdown. Use the second to spawn the evac immediately.

Post Reply